Jean-Sébastien DUCHENE Blog's

Actualité, Tips, Articles sur l'ensemble des Technologies Microsoft (SCCM/SMS, EMS, Microsoft Intune, Microsoft Azure, Windows 10, SCOM, MDOP...)

[SCCM CB] Erreur 1603 lors de l’installation/mise à jour de rôles de système de site (FSP, MP, Application Catalog, etc.)

Aujourd’hui en mettant à jour une de mes infrastructures System Center Configuration Manager, j’ai pu observer plusieurs installation/réinstallation de rôles de système de site échouer avec l’erreur : 1603.

Cela a notamment été le cas pour les rôles :

  • Fallback status point (smsfspsetup.log & fspMSI.log)
  • Management Point (mpsetup.log & mpMSI.log)
  • Application Catalog Web Service point (SMSAWEBSVCSetup.log & awebsvcMSI.log)
  • Application Catalog Web Site point (SMSPORTALWEBSetup.log & portlwebMSI.log)

L’erreur 1603 est générique et peut être en réalité la résultante de beaucoup de situations différentes. Je décris un des cas ici. Vous devez pour cela vous référer à l’erreur précise du fichier MSI.

L’ensemble de ces rôles et leurs MSI renvoyait des erreurs comme suit :

fsp.msi exited with return code: 1603

Backing up F:\Program Files\Microsoft Configuration Manager\logs\fspMSI.log to F:\Program Files\Microsoft Configuration Manager\logs\fspMSI.log.LastError

Fatal MSI Error - fsp.msi could not be installed.

 

En regardant dans l’un des fichiers MSI résultant, j’ai pu observer des erreurs comme suit :

[12:06:29] Processing Port List of WebSite [1]

[12:06:29] ERROR: Failed to get property value for 'certificateHash'. Error 0x80070057

[12:06:29] ERROR: GetSSLCertBindingInfo failed with error 0x80070057

[12:06:29] ERROR: Failed to configure sms ports '0x80070057'.

[12:06:29] ERROR: Failed to process port information.

[12:06:29] @@ERR:25011

MSI (s) (98!D4) [12:06:29:997]: Product: Application Web Service -- Internal Error 25011. 80070057

Internal Error 25011. 80070057

CustomAction CcmCreateIISVirtualDirectories returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

 

En regardant de plus près, le problème de configuration vient du site web IIS utilisé. Ouvrez alors la configuration du site IIS via IIS Manager puis sélectionnez edit bindings… sur le site en question (la plupart du temps le site web par défaut) :

Vous avez ici plusieurs possibilités :

  • Soit, vous utilisez le mode HTTPS et le binding du certificat n’est plus correcte (sur Not Selected). Ceci peut être dû au fait que le certificat ait été supprimé du serveur ou autre. Dans ce cas, vous pouvez éditer le binding HTTPS et réassocier le certificat.
  • Soit, vous avez un problème de lecture de la configuration du site web IIS. Dans ce cas, vous pouvez supprimer le binding HTTPS pour le recréer.

 

Facebook Like
Anonymous