Christophe Troessaert

Blog sur les technologies Microsoft Exchange, System center et Windows Server

Aujourd’hui problème de certain utlisateurs qui, après une migration Exchange 2003 vers 2010, n’avaient plus accès à certain dossier dans les Public Folder.

En utilisant la MMC Public Folder j’ai malheureusement moi aussi un problème d’accès.

--------------------------------------------------------

Microsoft Exchange Error

--------------------------------------------------------

The following error(s) occurred while saving changes:

Add-PublicFolderClientPermission

Failed

Error:

Failed to modify the MAPI.NET table property of the object "000000001A447390AA6611CD9BC800AA002FC45A03005B6C4EC5DDE95D4CA3691ACA3CEE82890000003BF4F40000" on server "Exchange.contoso.com". See inner exception for more information.

MapiExceptionNonCanonicalACL: Unable to modify table. (hr=0x80004005, ec=2409)

Diagnostic context:

Lid: 40487 EMSMDBMT.EcDoRpcExt2 called [length=201]

Lid: 56871 EMSMDBMT.EcDoRpcExt2 returned [ec=0x0][length=332][latency=15]

Lid: 23226 --- ROP Parse Start ---

Lid: 27962 ROP: ropModifyACL [64]

Lid: 17082 ROP Error: 0x969

Lid: 27745

Lid: 21921 StoreEc: 0x969

Lid: 27962 ROP: ropExtendedError [250]

Lid: 1494 ---- Remote Context Beg ----

Lid: 26426 ROP: ropModifyACL [64]

Lid: 22086

Lid: 27128

Lid: 27232 StoreEc: 0x8004010F

Lid: 27128

Lid: 27232 StoreEc: 0x8004010F

Lid: 22086

Lid: 21970 StoreEc: 0x8004010F PropTag: 0x3D210102

Lid: 21970 StoreEc: 0x8004010F PropTag: 0x668F0040

Lid: 6671 StoreEc: 0x8004010F

Lid: 24976

Lid: 24952

Lid: 25472

Lid: 7972 StoreEc: 0x969

Lid: 26532

Lid: 4920 StoreEc: 0x969

Lid: 5119 StoreEc: 0x969

Lid: 5247 StoreEc: 0x969

Lid: 17916 StoreEc: 0x969

Lid: 4814 StoreEc: 0x969

Lid: 1750 ---- Remote Context End ----

Lid: 26849

Lid: 21817 ROP Failure: 0x969

Lid: 29150

Lid: 20446 StoreEc: 0x969

--------------------------------------------------------

OK

--------------------------------------------------------

Pour régler ce problème, utilisez Exfolders

https://gallery.technet.microsoft.com/Exchange-2010-SP1-ExFolders-e6bfd405

Pas de chance, la DB ne veut pas s’ouvrir !

clip_image001

Lors de ma migration de 2003 à 2010, le serveur ne pouvait pas se désinstaller et j’ai du supprimer le serveur via ADSI Edit et l’outil n’aprécie pas trop car le nettoyage n’était pas parfait.

Pour résoudre ce problème vous devez repartir dans ADSI Edit :

Ouvrir Configuration, Services, Microsoft Exchange, CN=Your Company, Administrative Groups

Vous allez voir 2 dossiers avec CN=Servers. Un des deux sera vide ( ancien administrative group ) . Supprimez le.

clip_image002

L’outil fonctionne correctement désormais

clip_image003

Selectionnez le dossier où vous n’avez pas les droits et effectuez un clique droit, clear permissions. Puis ajoutez les utilisateurs via Folder Permission.

Problème résolu Smile

Facebook Like
Anonymous